Which Android version do I need for BirdRing?

Switch language: nlNederlands

BirdRing works with Android 4.1 or newer. You can’t install BirdRing with an older Android version. Older Android versions miss some functions that are used by the BirdRing app. According to this dashboard 98% of the Android phones and tablets have version 4.1 or newer.
Also Google Maps must be installed, it is used by the location functions of BirdRing.